SassをCentOSに入れようとしてエラーになった話

Sassをお勉強しようとCentOSにインストールしようとしたら小ハマりしたのでメモ。

スポンサーリンク

SassをCentOSに入れようとしてエラーになった話

Sassはcssで変数とか使えて便利、けどコンパイルが必要、ということで、コンパイラであるところの「sass」をインストールしようとすると、まずgem、rubygemが必要なんですね。
とりあえずそこからインストール。
gemはrubygemというパッケージに入っているっぽい。

# yum install rubygem
読み込んだプラグイン:fastestmirror, langpacks
base                                                                                      | 3.6 kB  00:00:00
epel/x86_64/metalink                                                                      | 6.2 kB  00:00:00
epel-debuginfo/x86_64/metalink                                                            | 5.9 kB  00:00:00
epel-source/x86_64/metalink                                                               | 6.2 kB  00:00:00
extras                                                                                    | 3.4 kB  00:00:00
nginx                                                                                     | 2.9 kB  00:00:00
updates                                                                                   | 3.4 kB  00:00:00
Loading mirror speeds from cached hostfile
 * base: ftp.iij.ad.jp
 * epel: ftp.riken.jp
 * epel-debuginfo: ftp.riken.jp
 * epel-source: ftp.riken.jp
 * extras: ftp.iij.ad.jp
 * updates: ftp.iij.ad.jp
パッケージ rubygem は利用できません。
エラー: 何もしません

失敗・・・というか入らない。じゃぁrubyから入れてみるか・・・でやってみると・・・・

# yum install ruby

一緒にrubygemも入ってきました。これで一応準備完了。じゃぁgemを使ってsassをインストールします。

# gem install sass
Building native extensions.  This could take a while...
ERROR:  Error installing sass:
        ERROR: Failed to build gem native extension.

    /usr/bin/ruby extconf.rb
mkmf.rb can't find header files for ruby at /usr/share/include/ruby.h


Gem files will remain installed in /usr/local/share/gems/gems/ffi-1.9.18 for inspection.
Results logged to /usr/local/share/gems/gems/ffi-1.9.18/ext/ffi_c/gem_make.out

ん?ERRORとな。Failed to build gem native extension.と言われましても・・・わからんし。
こういう時はエラーメッセージで検索すると解決法が見つかるはず。
「ERROR: Failed to build gem native extension.」これで検索すると・・・結構Ruby on Railsのインストールの事例が多かったのですが、それっぽいのが見つかった。
お、Stack Overflowの日本語版。
ubuntu – gemを使ってインストールするとエラーがでる。 – スタック・オーバーフロー

ここにちょっとだけコメントのあるruby-dev、つまりruby-develパッケージを入れるとなんとかなるかも。

# yum install ruby-devel

ドキドキ・・・。

# gem install sass
Building native extensions.  This could take a while...
Successfully installed ffi-1.9.18
Fetching: rb-inotify-0.9.10.gem (100%)
Successfully installed rb-inotify-0.9.10
Fetching: sass-listen-4.0.0.gem (100%)
Successfully installed sass-listen-4.0.0
Fetching: sass-3.5.1.gem (100%)
Successfully installed sass-3.5.1
Parsing documentation for ffi-1.9.18
Installing ri documentation for ffi-1.9.18
Parsing documentation for rb-inotify-0.9.10
Installing ri documentation for rb-inotify-0.9.10
Parsing documentation for sass-listen-4.0.0
Installing ri documentation for sass-listen-4.0.0
Parsing documentation for sass-3.5.1
Installing ri documentation for sass-3.5.1
4 gems installed

いけたー!やったー!
ま、環境がこれで出来ただけなんですけどね。

この記事が気に入ったら
いいね!お願いします

スポンサーリンク

シェアする

  • このエントリーをはてなブックマークに追加

フォローする

スポンサーリンク